「DXライブラリ」に任意のコードを実行される脆弱性(JVN) | ScanNetSecurity[国内最大級のサイバーセキュリティ専門ポータルサイト]
2018.07.20(金)

「DXライブラリ」に任意のコードを実行される脆弱性(JVN)

脆弱性と脅威 セキュリティホール・脆弱性

独立行政法人 情報処理推進機構(IPA)および一般社団法人 JPCERT コーディネーションセンター(JPCERT/CC)は6月8日、山田巧氏が提供するWindowsソフトウェア開発用のオープンソースのライブラリ「DXライブラリ」に任意のコードが実行可能な脆弱性が存在すると「Japan Vulnerability Notes(JVN)」で発表した。CVSS v3による最大Base Scoreは8.1。

「DXライブラリ VisualC++用 Ver3.13f から Ver3.16b まで」「DXライブラリ BorlandC++用 Ver3.13f から Ver3.16b まで」「DXライブラリ Gnu C++用 Ver3.13f から Ver3.16b まで」には、printfDx() の処理に起因する、任意のコードが実行可能な脆弱性(CVE-2016-4819)が存在する。この脆弱性が悪用されると、細工された文字列を処理することで任意のコードを実行される可能性がある。JVNでは開発者に対し、対策済みのDXライブラリを使用してリビルドし、アプリケーションをアップデートするよう呼びかけている。
《吉澤 亨史( Kouji Yoshizawa )》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★
<b>★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★</b>

経営課題としてサイバーセキュリティに取り組む情報システム部門や、研究・開発・経営企画に携わる方へ向けた、創刊19年のセキュリティ情報サービス Scan PREMIUM を、貴社の事業リスク低減のためにご活用ください。

×