Windows版PHPに、OSコマンドを実行される脆弱性(JVN) | ScanNetSecurity[国内最大級のサイバーセキュリティ専門ポータルサイト]
2018.10.21(日)

Windows版PHPに、OSコマンドを実行される脆弱性(JVN)

IPAおよびJPCERT/CCは、The PHP Groupが提供する「PHP」にOSコマンドインジェクション脆弱性が存在すると「JVN」で発表した。

脆弱性と脅威 セキュリティホール・脆弱性
独立行政法人 情報処理推進機構(IPA)および一般社団法人 JPCERT コーディネーションセンター(JPCERT/CC)は7月17日、The PHP Groupが提供する「PHP」にOSコマンドインジェクション脆弱性が存在すると「Japan Vulnerability Notes(JVN)」で発表した。CVSSによるBase Scoreは6.8。

「Windows 版 PHP 5.6.10 より前のバージョン」「Windows 版 PHP 5.5.26 より前のバージョン」「Windows 版 PHP 5.4.42 より前のバージョン」には、OSコマンドインジェクションの脆弱性(CVE-2015-4642)が存在する。この脆弱性が悪用されると、細工されたパラメータを escapeshellarg 関数に処理させることで、任意のOSコマンドを実行される可能性がある。JVNでは、開発者が提供する情報をもとにパッチを適用するよう呼びかけている。
《吉澤 亨史( Kouji Yoshizawa )》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

(。・ω・)ゞ !!ScanNetSecurity創刊20周年特別キャンペーン実施中。会員限定 PREMIUM 記事読み放題。早割10月末迄。現在通常料金半額以下!!
<b>(。・ω・)ゞ !!ScanNetSecurity創刊20周年特別キャンペーン実施中。会員限定 PREMIUM 記事読み放題。早割<font color=10月末迄。現在通常料金半額以下!!">

サイバーセキュリティの専門誌 ScanNetSecurity は 1998年の創刊から20周年を迎え、感謝を込めた特別キャンペーンを実施中。創刊以来史上最大割引率。次は30周年が来るまでこの価格はもうありません

×