USB機器をネットワーク共有する「KCodes NetUSB」に深刻な脆弱性(JVN) | ScanNetSecurity[国内最大級のサイバーセキュリティ専門ポータルサイト]
2018.08.21(火)

USB機器をネットワーク共有する「KCodes NetUSB」に深刻な脆弱性(JVN)

脆弱性と脅威 セキュリティホール・脆弱性

独立行政法人 情報処理推進機構(IPA)および一般社団法人 JPCERT コーディネーションセンター(JPCERT/CC)は5月20日、KCodesが提供する「NetUSB カーネルドライバ」にバッファオーバーフローの脆弱性(CVE-2015-3036)が存在すると「Japan Vulnerability Notes(JVN)」で発表した。CVSSによる最大Base Scoreは5.7。KCodes NetUSBは、家庭用ルータ製品などのLinuxベースの組込み機(等)に接続されたUSB機器をネットワーク共有する「USB over IP」機能を実現するLinuxカーネルモジュールであり、多くの製品が影響を受ける可能性がある。

クライアントがNetUSBサーバに接続する際に送信するデータをNetUSBカーネルドライバが適切に検証しないため、バッファオーバーフローが発生する可能性がある。この脆弱性が悪用されると、ローカルネットワーク上の攻撃者によってDoS攻撃を受けたり、任意のコードを実行される可能性がある。また、デバイスのデフォルトの設定次第では、リモートからの攻撃が可能である場合も考えられるとしている。JVNでは、開発者が提供する情報などをもとにファームウェアをアップデートするよう呼びかけている。またワークアラウンドとして、USBデバイスのネットワーク共有を無効にすることや、20005/tcp の通信をブロックすることを挙げている。
《吉澤 亨史( Kouji Yoshizawa )》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★
<b>★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★</b>

経営課題としてサイバーセキュリティに取り組む情報システム部門や、研究・開発・経営企画に携わる方へ向けた、創刊19年のセキュリティ情報サービス Scan PREMIUM を、貴社の事業リスク低減のためにご活用ください。

×