アプリ開発支援プラットフォーム「アプリカン」に複数の脆弱性(JVN) | ScanNetSecurity[国内最大級のサイバーセキュリティ専門ポータルサイト]
2018.07.21(土)

アプリ開発支援プラットフォーム「アプリカン」に複数の脆弱性(JVN)

脆弱性と脅威 セキュリティホール・脆弱性

独立行政法人 情報処理推進機構(IPA)および一般社団法人 JPCERT コーディネーションセンター(JPCERT/CC)は11月17日、株式会社ニューフォリアが提供するAndroidおよびiOS向けアプリケーションの開発支援プラットフォーム「アプリカン」に複数のスクリプトインジェクションの脆弱性が存在すると「Japan Vulnerability Notes(JVN)」で発表した。CVSSによる最大Base Scoreは6.8。

「Android 版 アプリカン 1.12.6 およびそれ以前で作成されたアプリケーション」「iOS 版 アプリカン 1.12.3 およびそれ以前で作成されたアプリケーション」には、複数のスクリプトインジェクションの脆弱性(CVE-2015-7771、CVE-2015-7772)が存在する。この脆弱性が悪用されると、細工されたURLにアクセスしたり、細工されたSSIDを設定したアクセスポイントに接続することで、アプリカンで作成したアプリケーション上で任意のスクリプトが実行され、結果として任意のAPIを実行される可能性がある。JVNでは、開発者が提供する情報をもとに対策済みのランタイムエンジンでリビルドし、アプリをアップデートするよう呼びかけている。
《吉澤 亨史( Kouji Yoshizawa )》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★
<b>★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★</b>

経営課題としてサイバーセキュリティに取り組む情報システム部門や、研究・開発・経営企画に携わる方へ向けた、創刊19年のセキュリティ情報サービス Scan PREMIUM を、貴社の事業リスク低減のためにご活用ください。

×