「S2Struts」に任意のコマンドが実行される脆弱性(JVN) | ScanNetSecurity[国内最大級のサイバーセキュリティ専門ポータルサイト]
2018.05.25(金)

「S2Struts」に任意のコマンドが実行される脆弱性(JVN)

脆弱性と脅威 セキュリティホール・脆弱性

独立行政法人 情報処理推進機構(IPA)および一般社団法人 JPCERT コーディネーションセンター(JPCERT/CC)は7月15日、特定非営利活動法人 Seasar ファウンデーションが提供する、JavaのWebアプリケーションを作成するためのソフトウェアフレームワーク「S2Struts」にClassLoaderが操作可能な脆弱性(CVE-2014-3893)の影響を受けるApache Struts を使用していると「Japan Vulnerability Notes(JVN)」で発表した。

「S2Struts 1.2.12 およびそれ以前」「S2Struts 1.3.1 およびそれ以前」には、Apache Strutsと同様のClassLoaderが操作可能な脆弱性が存在する。この脆弱性が悪用されると、S2Strutsが動作しているサーバ上で、リモートの攻撃者にによって情報を取得されたり、任意のコードを実行される可能性がある。JVNでは、開発者が提供する情報を元に最新版へアップデートするよう呼びかけている。
《吉澤 亨史》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

人気過去記事

もっと見る

人気過去記事特集をもっと見る

カテゴリ別新着記事

★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★
<b>★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★</b>

経営課題としてサイバーセキュリティに取り組む情報システム部門や、研究・開発・経営企画に携わる方へ向けた、創刊19年のセキュリティ情報サービス Scan PREMIUM を、貴社の事業リスク低減のためにご活用ください。

×