BSD libc ライブラリに脆弱性、任意のコードを実行される可能性も(JVN) | ScanNetSecurity
2022.08.08(月)

BSD libc ライブラリに脆弱性、任意のコードを実行される可能性も(JVN)

IPAおよびJPCERT/CCは、BSD向けの基本ライブラリ「BSD libc」にバッファオーバーフローの脆弱性が存在すると「JVN」で発表した。

脆弱性と脅威 セキュリティホール・脆弱性
独立行政法人 情報処理推進機構(IPA)および一般社団法人 JPCERT コーディネーションセンター(JPCERT/CC)は12月7日、BSD向けの基本ライブラリ「BSD libc」にバッファオーバーフローの脆弱性が存在すると「Japan Vulnerability Notes(JVN)」で発表した。CVSS v3によるBase Scoreは8.1。

「BSD libc」のlink_ntoa() 関数には、obuf 変数に関する処理が原因でバッファオーバーフローの脆弱性(CVE-2016-6559)が存在する。想定される影響は、攻撃手法やアプリケーションによるライブラリの使用方法に依存するが、最悪の場合はアプリケーションの実行権限で任意のコードが実行される可能性がある。JVNでは、開発者が提供する情報をもとに最新版へアップデートするよう呼びかけている。

なお、FreeBSD開発者の分析によると、攻撃可能な状態で link_ntoa() 関数が実装されているアプリケーションは存在しないだろうとの見解を示している。
《吉澤 亨史( Kouji Yoshizawa )》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

「経理」「営業」「企画」「プログラミング」「デザイン」と並ぶ、事業で成功するためのビジネスセンスが「セキュリティ」
「経理」「営業」「企画」「プログラミング」「デザイン」と並ぶ、事業で成功するためのビジネスセンスが「セキュリティ」

ページ右上「ユーザー登録」から会員登録すれば会員限定記事を閲覧できます。毎週月曜の朝、先週一週間のセキュリティ動向を総括しふりかえるメルマガをお届け。(写真:ScanNetSecurity 名誉編集長 りく)

×