アーカイブソフト「libarchive」に任意のコードを実行される脆弱性(JVN) | ScanNetSecurity
2021.10.20(水)

アーカイブソフト「libarchive」に任意のコードを実行される脆弱性(JVN)

IPAおよびJPCERT/CCは、libarchiveが提供するアーカイブソフト「libarchive」にバッファオーバーフローの脆弱性が存在すると「JVN」で発表した。

脆弱性と脅威 セキュリティホール・脆弱性
独立行政法人 情報処理推進機構(IPA)および一般社団法人 JPCERT コーディネーションセンター(JPCERT/CC)は5月6日、libarchiveが提供するアーカイブソフト「libarchive」にバッファオーバーフローの脆弱性が存在すると「Japan Vulnerability Notes(JVN)」で発表した。CVSS v3によるBase Scoreは6.3。

「libarchive version 3.2.0 より前のバージョン」には、入力値の検証不備が原因でバッファオーバーフローを引き起こされる脆弱性(CVE-2016-1541)が存在する。この脆弱性が悪用されると、細工されたZIPファイルを解凍することで、ユーザの権限で任意のコードを実行される可能性がある。JVNでは、開発者が提供する情報をもとに最新版(libarchive 3.2.0)へアップデートするよう呼びかけている。
《吉澤 亨史( Kouji Yoshizawa )》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

★★10/8~11/30迄 創刊23周年記念価格提供中★★
★★10/8~11/30迄 創刊23周年記念価格提供中★★

2021年10月8日(金)~11月30日(火) の間 ScanNetSecurity 創刊23周年記念価格で提供。

×