CADファイル用の「SXF 共通ライブラリ」にバッファオーバーフローの脆弱性(JVN) | ScanNetSecurity
2021.09.18(土)

CADファイル用の「SXF 共通ライブラリ」にバッファオーバーフローの脆弱性(JVN)

IPAおよびJPCERT/CCは、オープンCADフォーマット評議会が提供する、SXF形式のCADファイルを入出力するためのライブラリ「SXF 共通ライブラリ」にバッファオーバーフローの脆弱性が存在すると「JVN」で発表した。

脆弱性と脅威 セキュリティホール・脆弱性
独立行政法人 情報処理推進機構(IPA)および一般社団法人 JPCERT コーディネーションセンター(JPCERT/CC)は5月22日、オープンCADフォーマット評議会が提供する、SXF形式のCADファイルを入出力するためのライブラリ「SXF 共通ライブラリ」にバッファオーバーフローの脆弱性(CVE-2015-2946)が存在すると「Japan Vulnerability Notes(JVN)」で発表した。CVSSによる最大Base Scoreは6.8。

「SXF 共通ライブラリ Ver.3.21 およびそれ以前」には、入力データの処理が原因でバッファオーバーフローを引き起こされる脆弱性が存在する。この脆弱性が悪用されると、細工されたCADファイルを処理することで任意のコードを実行される可能性がある。オープンCADフォーマット評議会では、5月20日に脆弱性を解消した新バージョン「Ver.3.30」を公開しており、JVNでは情報をもとに最新版へアップデートするよう呼びかけている。
《吉澤 亨史( Kouji Yoshizawa )》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

「経理」「営業」「企画」「プログラミング」「デザイン」と並ぶ、事業で成功するためのビジネスセンスが「セキュリティ」
「経理」「営業」「企画」「プログラミング」「デザイン」と並ぶ、事業で成功するためのビジネスセンスが「セキュリティ」

ページ右上「ユーザー登録」から会員登録すれば会員限定記事を閲覧できます。毎週月曜の朝、先週一週間のセキュリティ動向を総括しふりかえるメルマガをお届け。(写真:ScanNetSecurity 名誉編集長 りく)

×