「POCO C++ Libraries」にワイルドカード証明書を適切に検証しない脆弱性(JVN) | ScanNetSecurity[国内最大級のサイバーセキュリティ専門ポータルサイト]
2018.09.20(木)

「POCO C++ Libraries」にワイルドカード証明書を適切に検証しない脆弱性(JVN)

IPAおよびJPCERT/CCは、Applied Informatics Software Engineering GmbHが提供する「POCO C++ Libraries」のNetSSLライブラリに、ワイルドカード証明書を適切に検証しない脆弱性が存在すると「JVN」で発表した。

脆弱性と脅威 セキュリティホール・脆弱性
独立行政法人 情報処理推進機構(IPA)および一般社団法人 JPCERT コーディネーションセンター(JPCERT/CC)は4月25日、Applied Informatics Software Engineering GmbHが提供する「POCO C++ Libraries」のNetSSLライブラリに、ワイルドカード証明書を適切に検証しない脆弱性(CVE-2014-0350)が存在すると「Japan Vulnerability Notes(JVN)」で発表した。

POCO C++ LibrariesのNetSSLライブラリ「1.4.6p2 およびそれ以前」「開発版 1.5.0 から1.5.2 まで」は、Poco::Net::X509Certificate::verify() の処理が原因でワイルドカード証明書を適切に検証しない脆弱性が存在する。この脆弱性が悪用されると、第三者によって、DNSスプーフィング攻撃、およびSSL/TLSクライアントが信用している認証局(CA)を最上位とする証明書チェーンを持つサーバ証明書が使われた場合、不適切な証明書にもかかわらず検証に成功してしまう可能性がある。JVNでは、ベンダが提供する情報を元に最新版へアップデートするよう呼びかけている。
《吉澤 亨史( Kouji Yoshizawa )》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★
<b>★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★</b>

経営課題としてサイバーセキュリティに取り組む情報システム部門や、研究・開発・経営企画に携わる方へ向けた、創刊19年のセキュリティ情報サービス Scan PREMIUM を、貴社の事業リスク低減のためにご活用ください。

×