Linux Kernel のパフォーマンスイベントの取り扱いに起因する権限昇格の脆弱性(Scan Tech Report) | ScanNetSecurity[国内最大級のサイバーセキュリティ専門ポータルサイト]
2018.06.24(日)

Linux Kernel のパフォーマンスイベントの取り扱いに起因する権限昇格の脆弱性(Scan Tech Report)

脆弱性と脅威 エクスプロイト

1.概要
Linux Kernel には、パフォーマンスイベントの取り扱いに起因して、権限昇格が可能な脆弱性が存在します。
システムにアクセス可能なローカルの悪意あるユーザに利用された場合、root権限を取得され、システムを完全に制御される可能性があります。
脆弱性を悪用された場合の影響度が高いため、影響を受けるバージョンの Linux Kernel を利用するユーザは可能な限り以下の対策を実施することを推奨します。


2.深刻度(CVSS)
7.2
http://nvd.nist.gov/cvss.cfm?version=2&name=CVE-2013-2094&vector=%28AV3AL/AC%3AL/Au%3AN/C%3AC/I%3AC/A%3AC%29


3.影響を受けるソフトウェア ※
Linux Kernel 2.6.37 - 3.0.74/3.2.44/3.4.41/3.8.8

※ 影響を受けるバージョンの Linux Kernel が実装される CentOS, Debian, Red Hat Enterprise Linux, Ubuntu などの Linux ディストリビューションもこの脆弱性の影響を受けます。


4.解説
Linux Kernel の perf_event_open は、パフォーマンス情報を収集するプログラムのファイルディスクリプタを取得するシステムコールであり、パフォーマンスイベントを初期化する際に、perf_swevent_init() 関数を呼び出します。

Linux Kernel には、パフォーマンスイベントを取り扱う際に、perf_swevent_init() 関数 (kernel/events/core.c) において、64 ビットの
符号なし整数型のデータ (config) を 32 ビットの符号付き整数型のデータ (event_id) としてキャスト処理してしまう不備があります。
このため、config パラメータに負の値が指定された不正な perf_event_openシステムコールを処理した場合に、意図せず perf_swevent_enabled 配列が使用する領域外のメモリ領域にアクセスしてしまう脆弱性が存在します。

この脆弱性を利用することでシステムにアクセス可能なローカルの攻撃者は、root に権限昇格を行い、当該権限で任意のコマンドが実行可能となります。

なお、Linux Kernel 2.6.37 において追加された以下 linux.git のソースコードを適用する Linux Kernel 環境が、この脆弱性の影響を受けます。

Linux Kernel linux.git b0a873ebbf87bf38bf70b5e39a7cadc96099fa13
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=b0a873ebbf87bf38bf70b5e39a7cadc96099fa13


5.対策
以下の Web サイトを参考に Linux Kernel 3.0.75/3.2.45/3.4.42/3.8.9 以降を入手しアップデートする、あるいは修正パッチを入手し適用することで、この脆弱性を解消することが可能です。

Linux Kernel:
http://www.kernel.org/

Linux Kernel linux.git 8176cced706b5e5d15887584150764894e94e02f
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=8176cced706b5e5d15887584150764894e94e02f

また、Linux ディストリビューションにおいては、それぞれのベンダが提供するセキュリティアドバイザリを参考に、適切なパッケージを入手しアップデートすることで、この脆弱性を解消することが可能です。

・CentOS
CESA-2013:0830
http://lists.centos.org/pipermail/centos-announce/2013-May/019733.html

・Debian
DSA-2669
http://www.debian.org/security/2013/dsa-2669

・Red Hat
Does CVE-2013-2094 affect Red Hat Enterprise Linux and Red Hat Enterprise MRG?
https://access.redhat.com/site/solutions/373743

・Ubuntu
CVE-2013-2094
http://people.canonical.com/~ubuntu-security/cve/2013/CVE-2013-2094.html


6.ソースコード
(Web非公開)

(執筆:株式会社ラック サイバー脅威分析センター

※Web非公開該当コンテンツ閲覧をご希望の方はScan Tech Reportにご登録(有料)下さい。

Scan Tech Report
http://scan.netsecurity.ne.jp/archives/51916302.html
《吉澤 亨史》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★
<b>★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★</b>

経営課題としてサイバーセキュリティに取り組む情報システム部門や、研究・開発・経営企画に携わる方へ向けた、創刊19年のセキュリティ情報サービス Scan PREMIUM を、貴社の事業リスク低減のためにご活用ください。

×