PHP-CGIのquery stringの処理にコード実行などにつながる脆弱性(JVN) | ScanNetSecurity[国内最大級のサイバーセキュリティ専門ポータルサイト]
2018.09.24(月)

PHP-CGIのquery stringの処理にコード実行などにつながる脆弱性(JVN)

IPAおよびJPCERT/CCは、「PHP」に、CGIとして使用される設定においてquery stringをコマンドラインオプションとして認識してしまう脆弱性が存在するとJVNで発表した。

脆弱性と脅威 セキュリティホール・脆弱性
独立行政法人 情報処理推進機構(IPA)および一般社団法人 JPCERT コーディネーションセンター(JPCERT/CC)は5月7日、国内でもポピュラーなWebアプリケーションの開発言語である、The PHP Groupが提供する「PHP」に、CGIとして使用される設定においてquery stringをコマンドラインオプションとして認識してしまう脆弱性が存在すると「Japan Vulnerability Notes(JVN)」で発表した。

影響を受けるシステムは、「PHP version 5.4.2 より前のバージョン」および「PHP version 5.3.12 より前のバージョン」。本脆弱性(CVE-2012-1823
)が悪用されると、リモートの攻撃者によってphpスクリプトの内容を取得されたり、DoS攻撃を受ける、Webサーバの権限で任意のコードを実行されるなどの影響を受ける可能性がある。現時点で対策方法は公開されておらず、開発者によると5月8日に追加アップデートを公開する予定だという。また、これにより影響を受けるシステムの情報が変更される可能性もある。JVNでは対策版を適用するまでの間、mod_rewrite による書き換えルールを設定することで、本脆弱性の影響を軽減することが可能としている。
《吉澤 亨史( Kouji Yoshizawa )》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★
<b>★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★</b>

経営課題としてサイバーセキュリティに取り組む情報システム部門や、研究・開発・経営企画に携わる方へ向けた、創刊19年のセキュリティ情報サービス Scan PREMIUM を、貴社の事業リスク低減のためにご活用ください。

×