Typora に JavaScript コードの無効化処理が不十分な問題 | ScanNetSecurity
2022.12.10(土)

Typora に JavaScript コードの無効化処理が不十分な問題

独立行政法人情報処理推進機構(IPA)および一般社団法人JPCERT コーディネーションセンター(JPCERT/CC)は11月21日、Typora における JavaScript コードの無効化処理が不十分な問題について「Japan Vulnerability Notes(JVN)」で発表した。

脆弱性と脅威 セキュリティホール・脆弱性

 独立行政法人情報処理推進機構(IPA)および一般社団法人JPCERT コーディネーションセンター(JPCERT/CC)は11月21日、Typora における JavaScript コードの無効化処理が不十分な問題について「Japan Vulnerability Notes(JVN)」で発表した。株式会社Flatt Securityの森瑛司氏が報告を行っている。影響を受けるシステムは以下の通り。

Typora 1.4.4 より前のバージョン

 Typora には、編集内容に含まれる JavaScript コードの一部に対して無効化処理が行われない問題が存在し、当該製品を使用してファイルを開いたときにファイルに含まれている JavaScript コードが実行される可能性がある。

 JVNでは、開発者が提供する情報をもとに、最新版にアップデートするよう呼びかけている。

《ScanNetSecurity》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

「経理」「営業」「企画」「プログラミング」「デザイン」と並ぶ、事業で成功するためのビジネスセンスが「セキュリティ」
「経理」「営業」「企画」「プログラミング」「デザイン」と並ぶ、事業で成功するためのビジネスセンスが「セキュリティ」

ページ右上「ユーザー登録」から会員登録すれば会員限定記事を閲覧できます。毎週月曜の朝、先週一週間のセキュリティ動向を総括しふりかえるメルマガをお届け。(写真:ScanNetSecurity 名誉編集長 りく)

×