WordPress のプラグイン Social Warfare において遠隔のファイルを読み込み任意のコードを実行されてしまう脆弱性(Scan Tech Report) | ScanNetSecurity
2024.06.16(日)

WordPress のプラグイン Social Warfare において遠隔のファイルを読み込み任意のコードを実行されてしまう脆弱性(Scan Tech Report)

WordPress のプラグインである Social Warfare において、読み込み先 URL の検証不備によって、遠隔から任意のコードが実行されてしまう脆弱性が報告されています。

脆弱性と脅威 エクスプロイト
◆概要

 WordPress のプラグインである Social Warfare において、読み込み先 URL の検証不備によって、遠隔から任意のコードが実行されてしまう脆弱性が報告されています。攻撃者が脆弱性の悪用に成功した場合は、WordPress を稼働している Web サーバの権限で遠隔から任意のコードを実行されてしまいます。プラグインのアップデートなどにより対策してください。

◆分析者コメント

 当該脆弱性では脆弱性を悪用する際に wp-admin 配下のコンテンツを参照する必要がありますが、脆弱性の対象となるコンテンツを閲覧するために認証を必要としないため、攻撃が容易な脆弱性であると考えられます。当該脆弱性を悪用することで、容易に対象ホストへの侵入が可能となるため、攻撃者に狙われ易いと考えられる脆弱性です。WordPress を運用している場合は、当該プラグインの利用状況を確認し、アップデートなどにより早急に対策することを推奨します。

◆深刻度(CVSS)

[CVSS v3]
6.1
https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator?name=CVE-2019-9978&vector=AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

[CVSS v2]
4.3
https://nvd.nist.gov/vuln-metrics/cvss/v2-calculator?name=CVE-2019-9978&vector=(AV:N/AC:M/Au:N/C:N/I:P/A:N)

◆影響を受けるソフトウェア

 Social Warfare のバージョン 3.5.3 未満が当該脆弱性の影響を受けると報告されています。

◆解説

 SNS に関連する統計情報を収集する WordPress のプラグインである Social Warfare に、遠隔から任意のコードが実行可能となる脆弱性が報告されています。
《株式会社ラック デジタルペンテスト部》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

「経理」「営業」「企画」「プログラミング」「デザイン」と並ぶ、事業で成功するためのビジネスセンスが「セキュリティ」
「経理」「営業」「企画」「プログラミング」「デザイン」と並ぶ、事業で成功するためのビジネスセンスが「セキュリティ」

ページ右上「ユーザー登録」から会員登録すれば会員限定記事を閲覧できます。毎週月曜の朝、先週一週間のセキュリティ動向を総括しふりかえるメルマガをお届け。(写真:ScanNetSecurity 名誉編集長 りく)

×