libssh において認証を回避して遠隔から任意のコードが実行可能となる脆弱性(Scan Tech Report) | ScanNetSecurity[国内最大級のサイバーセキュリティ専門ポータルサイト]
2018.12.19(水)

libssh において認証を回避して遠隔から任意のコードが実行可能となる脆弱性(Scan Tech Report)

SSH ライブラリソフトウェアである libssh に、認証機能の実装の不備に起因する、遠隔コード実行の脆弱性が報告されています。

脆弱性と脅威 エクスプロイト
◆概要

SSH ライブラリソフトウェアである libssh に、認証を回避して遠隔から任意のコードが実行可能となる脆弱性が報告されています。脆弱性を悪用されてしまった場合、攻撃者により遠隔から悪意のあるコードを実行されて、サーバの制御を奪われてしまいます。ソフトウェアのアップデートにより対策してください。

◆分析者コメント

SSH の機能を損なう深刻な脆弱性ですが、OpenSSH と比べると libssh を利用しているサーバがあまりないため、社会的影響度は高くないと考えられます。SSH は遠隔コード実行につながる脆弱性が少ないため、多くの SSH の脆弱性ではアクセス制御により対策することで充分な対策になると考えられます。しかし、本脆弱性は認証を回避して容易に任意の OS コマンドを実行させることが可能となる脆弱性であるため、アクセス制御を間違えた時の危険性を考慮して、アップデートにより対策してください。

◆深刻度(CVSS)

[CVSS v2]
6.4
https://nvd.nist.gov/vuln-metrics/cvss/v2-calculator?name=CVE-2018-10933&vector=(AV:N/AC:L/Au:N/C:P/I:P/A:N)

[CVSS v3]
9.1
https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator?name=CVE-2018-10933&vector=AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

◆影響を受けるソフトウェア

libssh のバージョン 0.6 以上で、0.7.6 未満または 0.8.4 未満が当該脆弱性の影響を受けると報告されています。

◆解説

SSH ライブラリソフトウェアである libssh に、認証機能の実装の不備に起因する、遠隔コード実行の脆弱性が報告されています。
《株式会社ラック サイバー・グリッド研究所》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★
<b>★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★</b>

経営課題としてサイバーセキュリティに取り組む情報システム部門や、研究・開発・経営企画に携わる方へ向けた、創刊20年のセキュリティ情報サービス Scan PREMIUM を、貴社の事業リスク低減のためにご活用ください。

×