git コマンドにおけるディレクトリトラバーサルにより遠隔から任意のコードが実行可能となる脆弱性(Scan Tech Report) | ScanNetSecurity[国内最大級のサイバーセキュリティ専門ポータルサイト]
2018.10.18(木)

git コマンドにおけるディレクトリトラバーサルにより遠隔から任意のコードが実行可能となる脆弱性(Scan Tech Report)

git コマンドに値検証不備に起因する遠隔コード実行の脆弱性が報告されています。

脆弱性と脅威 エクスプロイト
◆概要

git コマンドに値検証不備に起因する遠隔コード実行の脆弱性が報告されています。攻撃者が作成した悪意のあるレポジトリに対して git コマンドを実行した際に、任意のコードが実行されてしまう可能性があります。アップデート
により対策してください。

◆分析者コメント

クライアントの動作が必要となる脆弱性であり、あまり対策が及ばないと考えられる脆弱性ですが、ソフトウェアによっては暗黙的に使われている可能性が高いコマンドであると考えられます。日頃 git コマンドが参照しているリポジトリが汚染されてしまった場合は、被害を受けてしまう可能性があるため、アップデートにより対策することを推奨します。

◆深刻度(CVSS)

本記事執筆時点 (2018 年 6 月 7 日) で CVSS 値の情報公開を確認していません。

◆影響を受けるソフトウェア

以下のバージョンの git コマンドが影響を受けると報告されています。

  ・GIT 2.17
  ・GIT 2.16.3
  ・GIT 2.16
  ・GIT 2.15.1
  ・GIT 2.15
  ・GIT 2.14.3
  ・GIT 2.14.2
  ・GIT 2.14.1
  ・GIT 2.14
  ・GIT 2.13.6
  ・GIT 2.13.5
  ・GIT 2.13.4
  ・GIT 2.13.3
  ・GIT 2.13.2
  ・GIT 2.13.1
  ・GIT 2.13

◆解説

git コマンドに、ディレクトリトラバーサルにより遠隔から任意のコマンドが実行可能となる脆弱性が報告されています。
《株式会社ラック サイバー・グリッド研究所》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

(。・ω・)ゞ !!ScanNetSecurity創刊20周年特別キャンペーン実施中。会員限定 PREMIUM 記事読み放題。早割10月末迄。現在通常料金半額以下!!
<b>(。・ω・)ゞ !!ScanNetSecurity創刊20周年特別キャンペーン実施中。会員限定 PREMIUM 記事読み放題。早割<font color=10月末迄。現在通常料金半額以下!!">

サイバーセキュリティの専門誌 ScanNetSecurity は 1998年の創刊から20周年を迎え、感謝を込めた特別キャンペーンを実施中。創刊以来史上最大割引率。次は30周年が来るまでこの価格はもうありません

×