オムロン製FA統合ツールパッケージに複数の脆弱性(JVN) | ScanNetSecurity[国内最大級のサイバーセキュリティ専門ポータルサイト]
2018.07.20(金)

オムロン製FA統合ツールパッケージに複数の脆弱性(JVN)

脆弱性と脅威 セキュリティホール・脆弱性

独立行政法人 情報処理推進機構(IPA)および一般社団法人 JPCERT コーディネーションセンター(JPCERT/CC)は4月11日、オムロン株式会社が提供するFA統合ツールパッケージ「CX-One」に含まれるアプリケーションに、複数の脆弱性が存在すると「Japan Vulnerability Notes(JVN)」で発表した。CVSS v3による最大Base Scoreは5.3。影響を受けるシステムは次の通り。

CX-One Version 4.4.2 およびそれ以前に含まれる
・CX-FLnet Version 1.00 およびそれ以前
・CX-Protocol Version 1.992 およびそれ以前
・CX-Programmer Version 9.65 およびそれ以前
・CX-Server Version 5.0.22 およびそれ以前
・Network Configurator Version 3.63 およびそれ以前
・Switch Box Utility Version 1.68 およびそれ以前

これらには、スタックベースのバッファオーバーフロー(CVE-2018-7514)、不適切な型を使用したリソースへのアクセス(型の取り違え)(CVE-2018-7530)、ヒープベースのバッファオーバーフロー(CVE-2018-8834)の脆弱性が存在する。これらの脆弱性が悪用されると、リモートの第三者により任意のコードを実行される可能性がある。JVNでは、開発者が提供する情報をもとに最新版へアップデートするよう呼びかけている。
《吉澤 亨史( Kouji Yoshizawa )》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★
<b>★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★</b>

経営課題としてサイバーセキュリティに取り組む情報システム部門や、研究・開発・経営企画に携わる方へ向けた、創刊19年のセキュリティ情報サービス Scan PREMIUM を、貴社の事業リスク低減のためにご活用ください。

×