Webアプリフレームワーク「Symfony」にコードインジェクションの脆弱性(JVN) | ScanNetSecurity[国内最大級のサイバーセキュリティ専門ポータルサイト]
2018.02.23(金)

Webアプリフレームワーク「Symfony」にコードインジェクションの脆弱性(JVN)

脆弱性と脅威 セキュリティホール・脆弱性

独立行政法人 情報処理推進機構(IPA)および一般社団法人 JPCERT コーディネーションセンター(JPCERT/CC)は6月23日、SensioLabsが提供する、オープンソースのWebアプリケーションフレームワーク「Symfony」にコードインジェクションの脆弱性が存在すると「Japan Vulnerability Notes(JVN)」で発表した。CVSSによるBase Scoreは6.8。

「SymfonySymfony 2.0.x、2.1.x、2.2.x、2.3.x、2.4.x、2.5.x、2.6.x」には、コードインジェクションの脆弱性(CVE-2015-2308)が存在する。Symfonyを使用するアプリケーションにおいて、リバースプロキシ機能(HttpCache クラス)を使用し ESIサポートを有効にしている場合に、本脆弱性の影響を受ける。この脆弱性が悪用されると、Symfonyを使用するアプリケーションが動作するサーバ上で、任意のPHPコードを実行される可能性がある。JVNでは、開発者が提供する情報をもとに最新版へアップデートするよう呼びかけている。
《吉澤 亨史》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★
<b>★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★</b>

経営課題としてサイバーセキュリティに取り組む情報システム部門や、研究・開発・経営企画に携わる方へ向けた、創刊19年のセキュリティ情報サービス Scan PREMIUM を、貴社の事業リスク低減のためにご活用ください。

×