Apache Struts において namespace の値検証不備により任意のコードが実行可能となる脆弱性(Scan Tech Report) | ScanNetSecurity[国内最大級のサイバーセキュリティ専門ポータルサイト]
2018.10.21(日)

Apache Struts において namespace の値検証不備により任意のコードが実行可能となる脆弱性(Scan Tech Report)

Web アプリケーションの開発フレームワークとして、世界的に利用されているApache Struts 2 に、遠隔から任意のコードが実行可能となる脆弱性が公開されています。

脆弱性と脅威 エクスプロイト
◆概要

 Apache 財団が公開している Web アプリケーションの開発フレームワークである Apache Struts に、遠隔から任意のコードが実行可能となる脆弱性が、報告されています。攻撃者に脆弱性を悪用されてしまった場合、意図しない動作を強制され重大な情報セキュリティ事故が発生してしまう可能性が考えられます。脆弱性に対応したバージョンが公開されているため、アップデートを適用することにより対策してください。

◆分析者コメント

 Struts のバージョン 1 系への影響が懸念される脆弱性ではありますが、遠隔コード実行を引き起こす手法が Struts のバージョン 2 系から導入された機能である OGNL 式の挿入によるものであるため、Struts のバージョン 1 系に影響が及ぶ可能性は低いと考えられます。今回報告された脆弱性は、過去に報告された Struts の遠隔コード実行の脆弱性の中でも設定条件が厳しいため、脆弱性による被害を受ける可能性は低いですが、念のためアップデートを適用して根本的な対策をすることを推奨します。

◆深刻度(CVSS)

 本記事執筆時点 (2018 年 9 月 17 日) で CVSS 値の情報は公開されていません。

◆影響を受けるソフトウェア

 Apache Struts 2 系の以下のバージョンが脆弱性の影響を受けます。

  - Struts 2.3 系: Struts 2.3.35 より前のバージョン
  - Struts 2.5 系: Struts 2.5.17 より前のバージョン

 脆弱性の影響を受けるバージョンの範囲については、Apache Struts 2 のうちサポートされているバージョンのみの情報しか公開されていません。Apache Struts 2 のうちサポートされていないバージョンでも当該脆弱性の影響を受ける可能性が高いため、Struts 2.3 系または Struts 2.5 系の最新バージョンへのアップデートを推奨します。

◆解説

 Web アプリケーションの開発フレームワークとして、世界的に利用されているApache Struts 2 に、遠隔から任意のコードが実行可能となる脆弱性が公開されています。
《株式会社ラック サイバー・グリッド研究所》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

(。・ω・)ゞ !!ScanNetSecurity創刊20周年特別キャンペーン実施中。会員限定 PREMIUM 記事読み放題。早割10月末迄。現在通常料金半額以下!!
<b>(。・ω・)ゞ !!ScanNetSecurity創刊20周年特別キャンペーン実施中。会員限定 PREMIUM 記事読み放題。早割<font color=10月末迄。現在通常料金半額以下!!">

サイバーセキュリティの専門誌 ScanNetSecurity は 1998年の創刊から20周年を迎え、感謝を込めた特別キャンペーンを実施中。創刊以来史上最大割引率。次は30周年が来るまでこの価格はもうありません

×