「Zend Framework」にSQLインジェクションの脆弱性(JVN) | ScanNetSecurity
2022.08.12(金)

「Zend Framework」にSQLインジェクションの脆弱性(JVN)

IPAおよびJPCERT/CCは、Zend Frameworkが提供するオープンソースのWebアプリケーションフレームワークである「Welcart」にSQLインジェクションの脆弱性が存在すると「JVN」で発表した。

脆弱性と脅威 セキュリティホール・脆弱性
独立行政法人 情報処理推進機構(IPA)および一般社団法人 JPCERT コーディネーションセンター(JPCERT/CC)は9月15日、Zend Frameworkが提供するオープンソースのWebアプリケーションフレームワークである「Welcart」にSQLインジェクションの脆弱性が存在すると「Japan Vulnerability Notes(JVN)」で発表した。CVSS v3によるBase Scoreは8.1。

「Zend Framework 1.12.20 より前のバージョン」には、ORDER BY句および GROUP BY句の引数の処理が原因でSQLインジェクションの脆弱性(CVE-2016-4861)が存在する。この脆弱性が悪用されると、リモートの第三者によってデータベース内の情報を取得されたり、改ざんされる可能性がある。JVNでは、開発者が提供する情報をもとに最新版へアップデートするよう呼びかけている。
《吉澤 亨史( Kouji Yoshizawa )》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

「経理」「営業」「企画」「プログラミング」「デザイン」と並ぶ、事業で成功するためのビジネスセンスが「セキュリティ」
「経理」「営業」「企画」「プログラミング」「デザイン」と並ぶ、事業で成功するためのビジネスセンスが「セキュリティ」

ページ右上「ユーザー登録」から会員登録すれば会員限定記事を閲覧できます。毎週月曜の朝、先週一週間のセキュリティ動向を総括しふりかえるメルマガをお届け。(写真:ScanNetSecurity 名誉編集長 りく)

×