Ruby on Rails において Render メソッドの実装不備により遠隔から任意のコードが実行されてしまう脆弱性(Scan Tech Report) | ScanNetSecurity
2020.12.03(木)

Ruby on Rails において Render メソッドの実装不備により遠隔から任意のコードが実行されてしまう脆弱性(Scan Tech Report)

Web アプリケーションフレームワークである Ruby on Rails において、動的なコンテンツ呼び出しに利用される Render メソッドの値検証不備に起因する遠隔コード実行の脆弱性が報告されています

脆弱性と脅威 エクスプロイト
◆概要
Web アプリケーションフレームワークである Ruby on Rails において、動的なコンテンツ呼び出しに利用される Render メソッドの値検証不備に起因する遠隔コード実行の脆弱性が報告されています。脆弱なバージョンの Rails で動作している Web アプリにおいて Render メソッドを用いているコンテンツが存在する場合、外部から Render メソッドに特殊な引数を入力することにより、遠隔から任意の Ruby コードを実行されてしまう可能性があります。
----------------------------------------------------------------------
◆分析者コメント
近年 Ruby on Rails を利用した Web アプリケーションも世界的に多いため、脆弱性の影響範囲は広いと考えられます。当該脆弱性は Rails の値検証不備に起因する問題では有りますが、アプリケーションの実装としては外部から Render メソッドを呼び出せてしまうことが好ましく無いと考えられるため、Ruby on Rails を利用した Web アプリケーションの運用者は運用しているアプリケーションに Render メソッドが用いられているかを確認するとともに、アプリケーションの実装についても見なおすことを推奨します。
----------------------------------------------------------------------
◆深刻度(CVSS)
[CVSS v2]
7.5
https://nvd.nist.gov/cvss/v2-calculator?name=CVE-2016-2098&vector=(AV:N/AC:L/Au:N/C:P/I:P/A:P)
[CVSS v3]
7.3
https://nvd.nist.gov/cvss/v3-calculator?name=CVE-2016-2098&vector=AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
----------------------------------------------------------------------
◆影響を受けるソフトウェア
バージョン 4.2.5.2 未満の Rails が当該脆弱性の影響を受けると報告されて
います。
《株式会社ラック デジタルペンテストサービス部》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

★★ ( FB ログイン可) 会員限定記事、週 1 回のメルマガ、人気ニュースランキング、特集一覧をお届け…無料会員登録はアドレスのみで所要 1 分程度 ★★
★★ ( FB ログイン可) 会員限定記事、週 1 回のメルマガ、人気ニュースランキング、特集一覧をお届け…無料会員登録はアドレスのみで所要 1 分程度 ★★

登録すれば、記事一覧、人気記事ランキング、BASIC 会員限定記事をすべて閲覧できます。毎週月曜朝には一週間のまとめメルマガをお届けします(BASIC 登録後 PREMIUM にアップグレードすれば全ての限定コンテンツにフルアクセスできます)。

×