2013年にサポートが終了している「Apache Struts1」に複数の脆弱性(JVN) | ScanNetSecurity[国内最大級のサイバーセキュリティ専門ポータルサイト]
2018.07.16(月)

2013年にサポートが終了している「Apache Struts1」に複数の脆弱性(JVN)

脆弱性と脅威 セキュリティホール・脆弱性

独立行政法人 情報処理推進機構(IPA)および一般社団法人 JPCERT コーディネーションセンター(JPCERT/CC)は6月7日、Webアプリケーションを構築するためのフレームワークである「Apache Struts 1」に複数の脆弱性が存在すると「Japan Vulnerability Notes(JVN)」で発表した。CVSS v3による最大Base Scoreは8.1。なお、「Apache Struts 1」は2013年4月5日にサポートを終了しており、対策方法や修正パッチの有無は各開発者によるとしている。

「Apache Struts バージョン 1.0 から 1.3.10 まで」には、ActionFormにServletやClassLoaderなど、サーバのメモリ上にあるコンポーネントを操作可能な脆弱性(CVE-2016-1181)、また「Apache Struts バージョン 1.1 から 1.3.10 まで」には、入力値検証に関する設定(検証ルールやエラーメッセージ)を変更される脆弱性(CVE-2016-1182)が存在する。JVNでは、各開発者が提供する情報をもとに対策を行うよう呼びかけている。
《吉澤 亨史( Kouji Yoshizawa )》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★
<b>★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★</b>

経営課題としてサイバーセキュリティに取り組む情報システム部門や、研究・開発・経営企画に携わる方へ向けた、創刊19年のセキュリティ情報サービス Scan PREMIUM を、貴社の事業リスク低減のためにご活用ください。

×