PHPライブラリ「namshi/jose」にトークンの署名検証回避の脆弱性(JVN) | ScanNetSecurity[国内最大級のサイバーセキュリティ専門ポータルサイト]
2018.06.21(木)

PHPライブラリ「namshi/jose」にトークンの署名検証回避の脆弱性(JVN)

脆弱性と脅威 セキュリティホール・脆弱性

独立行政法人 情報処理推進機構(IPA)および一般社団法人 JPCERT コーディネーションセンター(JPCERT/CC)は6月25日、Namshiが提供する、JSON Web Token(JWT)を扱うための PHP ライブラリ「namshi/jose」にトークンの署名検証回避の脆弱性が存在すると「Japan Vulnerability Notes(JVN)」で発表した。CVSSによるBase Scoreは5.0。

「namshi/jose 2.2.1 およびそれ以前」「namshi/jose 3.0.0 およびそれ以前」「namshi/jose 4.0.0 およびそれ以前」「namshi/jose 5.0.0 およびそれ以前」には、JWT のヘッダの処理に起因する、トークンの署名を適切に検証しない脆弱性(CVE-2015-2964)が存在する。この脆弱性が悪用されると、攻撃者によって細工されたJWTのデータを、正しく署名されたトークンとして扱ってしまう可能性がある。JVNでは、開発者が提供する情報をもとに最新版へアップデートするよう呼びかけている。
《吉澤 亨史》

関連記事

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★
<b>★★Scan PREMIUM 会員限定コンテンツにフルアクセスが可能となります★★</b>

経営課題としてサイバーセキュリティに取り組む情報システム部門や、研究・開発・経営企画に携わる方へ向けた、創刊19年のセキュリティ情報サービス Scan PREMIUM を、貴社の事業リスク低減のためにご活用ください。

×