開発言語PHPのunserialize()の入力検証部分にリモートから攻撃可能な脆弱性が見つかる | ScanNetSecurity
2020.11.26(木)

開発言語PHPのunserialize()の入力検証部分にリモートから攻撃可能な脆弱性が見つかる

 サイバーディフェンス社からの情報によると、複数のベンダが実装しているPHP GroupのPHPアプリケーション開発言語で、リモートから攻撃可能な脆弱性が見つかった。これにより、実行中のwebサーバの権限で任意のコードが実行される可能性がある。この脆弱性はunseriali

製品・サービス・業界動向 業界動向
 サイバーディフェンス社からの情報によると、複数のベンダが実装しているPHP GroupのPHPアプリケーション開発言語で、リモートから攻撃可能な脆弱性が見つかった。これにより、実行中のwebサーバの権限で任意のコードが実行される可能性がある。この脆弱性はunserialize()ルーチンの入力検証部分に存在する。ハッシュテーブルが破壊されると、任意のメモリアドレスでefree()が呼び出され、任意のコードが実行される可能性がある。さらに、以前のバージョンのunserializer変数が使用されると、すでに解放されている変数ハッシュエントリが参照される可能性がある。この場合も、任意のコードが実行される可能性がある。


※この情報は株式会社サイバーディフェンス
 ( http://www.cyberd.co.jp/ )より提供いただいております。
 サイバーディフェンス社の CyberNoticeBasic サービスの詳細については
 下記のアドレスまでお問い合せください。
 問い合わせ先: scan@ns-research.jp
 情報の内容は以下の時点におけるものです
 【15:34 GMT、2、15、2005】
《ScanNetSecurity》

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

★★10/15~11/30迄 創刊22周年記念価格提供中★★
★★10/15~11/30迄 創刊22周年記念価格提供中★★

2020年10月15日(木)~11月30日(月) の間 ScanNetSecurity 創刊22周年記念価格で提供。

×