Linuxの電子掲示板phpBBでHighlightパラメータの処理に入力検証の脆弱性が見つかる | ScanNetSecurity[国内最大級のサイバーセキュリティ専門ポータルサイト]
2018.11.21(水)

Linuxの電子掲示板phpBBでHighlightパラメータの処理に入力検証の脆弱性が見つかる

サイバーディフェンス社からの情報によると、複数のベンダのOSに実装されているphpBBに、リモートから攻撃可能な脆弱性が見つかった。これにより、任意のコードが実行される可能性がある。この脆弱性は入力検証部分に存在する。iDEFENSEでは、実環境で攻撃コードの存在を

製品・サービス・業界動向 業界動向
サイバーディフェンス社からの情報によると、複数のベンダのOSに実装されているphpBBに、リモートから攻撃可能な脆弱性が見つかった。これにより、任意のコードが実行される可能性がある。この脆弱性は入力検証部分に存在する。iDEFENSEでは、実環境で攻撃コードの存在を確認していない。パッチはリリースされており、暫定処置も公開されている。この問題は、viewtopic.phpのhighlightパラメータの処理部分で発生し、「重大な問題」とされている。preg_replace()関数は、highlightパラメータに渡されるユーザ入力を適切に検証しない。preg_replace()関数が特殊な「e」修飾子を使用する際に、PHPはこの置換文字をPHPコードとして処理する。これにより、PHPでphpinfo()関数が実行される。


※この情報は株式会社サイバーディフェンス
 ( http://www.cyberd.co.jp/ )より提供いただいております。
 サイバーディフェンス社の CyberNoticeBasic サービスの詳細については
 下記のアドレスまでお問い合せください。
 問い合わせ先: scan@ns-research.jp
 情報の内容は以下の時点におけるものです
 【16:52 GMT、6、29、2005】
《ScanNetSecurity》

Scan PREMIUM 会員限定記事

もっと見る

Scan PREMIUM 会員限定記事特集をもっと見る

カテゴリ別新着記事

(。・ω・)ゞ !!11月末迄 ScanNetSecurity創刊20周年特別キャンペーン実施中。会員限定 PREMIUM 記事読み放題。現在通常料金半額以下!!
(。・ω・)ゞ !!11月末迄 ScanNetSecurity創刊20周年特別キャンペーン実施中。会員限定 PREMIUM 記事読み放題。現在通常料金半額以下!!

サイバーセキュリティの専門誌 ScanNetSecurity は 1998年の創刊から20周年を迎え、感謝を込めた特別キャンペーンを実施中。創刊以来史上最大割引率。次は30周年が来るまでこの価格はもうありません!

×